forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Win 7 Problems

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Plato
View previous topic :: View next topic  
Author Message
stfark1



Joined: 02 Sep 2008
Posts: 167

PostPosted: Sun Dec 20, 2009 5:57 am    Post subject: Win 7 Problems Reply with quote

Hi Paul laidler: Not sure you got my previous message but these are things I discovered. I believe that there are at least two problems running Silverfrost program under Win 7. 1.) The linker has a problem with setting a "target" I have been running the Plato system under Win XP for about one year, no problems. When I switched to Win 7, the "Target" problems start to happen, the error I get is "target not set". However, I believe that this is because of problem 2.) The linker has a problem finding the .obj files output from the compiler. The linker always looks for the .obj files in Checkmate Win32 or Debug Win32. However, the compiler outputs the .obj files in the original directory where the .for files are, usually not the Checkmate Win32 file or the Debug Win32 file. I would like to assign the output from the compiler into a different file but not sure how to do this. What is strange however is that this just started to happen with Win 7. Anyway, what are your thoughts. Sid Kraft
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6393
Location: Salford, UK

PostPosted: Sun Dec 20, 2009 9:43 am    Post subject: Reply with quote

I cannot acount for the problems that you describe.
At the moment there is no reason to think that the change to Windows 7 is somehow relevant unless you now have limited access rights to the folders that you are using.

If there are problems with the Silverfrost software then they will probably be within Plato but until I get independent confirmation of your problems there is little that I can do.
Back to top
View user's profile Send private message AIM Address
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6393
Location: Salford, UK

PostPosted: Sun Dec 20, 2009 10:02 am    Post subject: Reply with quote

On further reflection I think that you may have copied your project file into the new computer/operating system and that the project file contains file names etc using different drive letters.

You should read the project file (something.ftn95prj) in a text editor such as Notepad and find the paths for the files and folders. These can be changed manually and saved.

Once you have sorted the problem out, you can change from absolute paths to relative paths in order to avoid the problem in future.
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Plato All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group