forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

%eb crashes during delay while processing cursor key input

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
steveDoyle



Joined: 04 Sep 2009
Posts: 86
Location: Manchester

PostPosted: Wed Dec 30, 2020 1:37 pm    Post subject: %eb crashes during delay while processing cursor key input Reply with quote

Hi, (Ftn95 8.70, win xp/32)

I use a %eb as a mini editor. It works as as expected until I use the cursor keys cursor keys to move around the text. The cursor does not move for about 5 seconds for each keypress. i.e. 2 quick cursor move = 10 second wait. If try and use another editor function (i.e. exit) during this delay the program crashes. if i wait fro the cursor to move there is no issue. If I used the mouse to move the cursor around the text there is no issue .

I will try and test it on a win10/64 system to see if it a legacy issue

steve

Here is the %eb call with options and some of the trace back message


CHARACTER*(32767) EQN_MODEL_BUFF_X

IWIN = WINIO@('%~`*.*eb[vscrollbar,hscrollbar,undo]&', IWIDTH,
+ IHEIGHT, EQN_MODEL_BUFF_X, EQN_BUFF_SIZE,
+ ED_INFO(EDI_DATA_EXIST_GREYED), EDIT_INFO_EQN)



Message 2

Runtime error from program:c:\apps_cpi\bin\sprint.exe
Access Violation
The instruction at address 0e58324c attempted to read from location 00000000
0e583231 strdup [+001b]
0e5b1256 GetTextExtentPoint_edit(<ptr>void,<ptr>char,int,<ptr>structÄtagSIZE)#70 [+0014]
0e5b4ccf locate_mouse(<ptr>structÄedit_buffer,int,int)#70 [+0228]
0e5b5570 edit_procedure@16 [+09c7]
7e418734 routine at address 7E418734 [+0000]


Message 2

Runtime error from program:c:\apps_cpi\bin\sprint.exe
Access Violation
The instruction at address 0e5b0051 attempted to read from location 00000128
0e5b0027 backup_one_utf8_char(<ref>(<ptr>char))#70 [+002a]
0e5b08a9 store_position_hint(<ptr>structÄedit_buffer,int)#70 [+0068]
0e5b5570 edit_procedure@16 [+1099]
7e418734 routine at address 7E418734 [+0000]
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6821
Location: Salford, UK

PostPosted: Wed Dec 30, 2020 2:56 pm    Post subject: Reply with quote

Steve

Can you provide a small working program that illustrates the failure?
Back to top
View user's profile Send private message AIM Address
steveDoyle



Joined: 04 Sep 2009
Posts: 86
Location: Manchester

PostPosted: Wed Dec 30, 2020 5:35 pm    Post subject: Reply with quote

Hi Paul

I will try to make smaller/simpler version and experiment on different platforms

I will let you know how i get on


thanks

steve
Back to top
View user's profile Send private message
steveDoyle



Joined: 04 Sep 2009
Posts: 86
Location: Manchester

PostPosted: Mon Jan 04, 2021 1:01 pm    Post subject: Reply with quote

Paul

this code demonstrates the problem. if you add text( inc cr/lf) in the middle of the numbers and then navigate using the cursor keys the response freezes and then the program crashes when closed
(ftn95 ed_test.for /lgo/win)
happy hunting

steve

PROGRAM EB_TEST
IMPLICIT NONE
INCLUDE <windows.ins>
INTEGER IWIN
INTEGER EDIT_INFO_EQN(24)
INTEGER EQN_BUFF_SIZE
CHARACTER*(32767) EQN_MODEL_BUFF_X
INTEGER IWIDTH, IHEIGHT
COMMON /FRED_1/ EQN_MODEL_BUFF_X, EQN_BUFF_SIZE, IWIDTH, IHEIGHT,
+ EDIT_INFO_EQN
IHEIGHT = 17
IWIDTH = 75
EQN_MODEL_BUFF_X = '1234567890 1234567890 1234567890' // CHAR(0)
IWIN = WINIO@('%ca@&', 'model sheet')
EQN_BUFF_SIZE = LEN(EQN_MODEL_BUFF_X)
IWIN = WINIO@('%`*.*eb[vscrollbar,hscrollbar,undo]&', IWIDTH,
+ IHEIGHT, EQN_MODEL_BUFF_X, EQN_BUFF_SIZE, EDIT_INFO_EQN)
IWIN = WINIO@('%ff')
END
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6821
Location: Salford, UK

PostPosted: Mon Jan 04, 2021 4:50 pm    Post subject: Reply with quote

This issue has now been fixed for the next release of ClearWin+.

The failure is in new code for handling UTF8 characters and these are not used in this code.

The failure when actually using UTF8 characters remains to be resolved.
Back to top
View user's profile Send private message AIM Address
steveDoyle



Joined: 04 Sep 2009
Posts: 86
Location: Manchester

PostPosted: Mon Jan 04, 2021 7:19 pm    Post subject: Reply with quote

Paul

It works fin with the development DLLs

Thanks for the quick response

steve
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group