forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Unknown symbols for ftn95 version 8.60

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
DietmarSiepmann



Joined: 03 Jun 2013
Posts: 239

PostPosted: Thu Jan 16, 2020 9:50 am    Post subject: Unknown symbols for ftn95 version 8.60 Reply with quote

Hello,

we make use of Open GL for our 32 bit builds and found that the following symbols are unknown for ftn95 version 8.60:

Code:

glBindTexture
glDeleteTextures
glGenTextures


Regards
Dietmar
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6472
Location: Salford, UK

PostPosted: Thu Jan 16, 2020 11:20 am    Post subject: Reply with quote

Dietmar

These are OpenGL functions so my first thought is that they must be missing from the 64 bit OpenGL library. I can take a look in the relevant DLLs.

If this is true then they will also be missing for previous releases of FTN95.
Back to top
View user's profile Send private message AIM Address
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6472
Location: Salford, UK

PostPosted: Thu Jan 16, 2020 11:53 am    Post subject: Reply with quote

These functions are in OpenGL32.dll and appear to be present in the 64 bit version.

Was this a problem when using the v8.5x release of the compiler?

Are you including OpenGL32.dll in your link script?
Back to top
View user's profile Send private message AIM Address
DietmarSiepmann



Joined: 03 Jun 2013
Posts: 239

PostPosted: Thu Jan 16, 2020 12:44 pm    Post subject: Reply with quote

Paul,

sorry, I forgot to tell you that these errors occurred when compiling *.cpp files. The exact error message was e.g.:
*** Function 'glGenTextures' has not been declared

I found a declaration of glBindTexture in file
Code:

include\WIN32\GL\GL.H

of ftn95 version 7.10 and 8.50, but not for 8.60.

The same holds for the two other symbols.

Regards,
Dietmar
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6472
Location: Salford, UK

PostPosted: Thu Jan 16, 2020 1:17 pm    Post subject: Reply with quote

Dietmar

Can you copy the good gl.h for v8.50 to the "include\WIN32\GL" for v8.60.

I will try to work out what has gone wrong and fix it for the next release.
Back to top
View user's profile Send private message AIM Address
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6472
Location: Salford, UK

PostPosted: Thu Jan 16, 2020 2:31 pm    Post subject: Reply with quote

Dietmar

Can you send me a copy of your gl.h that contains these functions.

At the moment I can't find a Silverfrost version that has them.
Back to top
View user's profile Send private message AIM Address
DietmarSiepmann



Joined: 03 Jun 2013
Posts: 239

PostPosted: Thu Jan 16, 2020 2:33 pm    Post subject: Reply with quote

Paul,

thanks, having copied the good gl.h from ftn95 version 8.50 to version 8.60 helped.

Regards,
Dietmar
Back to top
View user's profile Send private message
DietmarSiepmann



Joined: 03 Jun 2013
Posts: 239

PostPosted: Thu Jan 16, 2020 3:37 pm    Post subject: Reply with quote

Paul,

do you still need the good gl.h (of ftn95 version 8.50)? For me this is not urgent anymore because I'm fine with the hint you suggessted. If yes, how would I send it to you?

Regards,
Dietmar
Back to top
View user's profile Send private message
DietmarSiepmann



Joined: 03 Jun 2013
Posts: 239

PostPosted: Thu Apr 02, 2020 1:51 pm    Post subject: Reply with quote

Paul,

symbols
Code:

glBindTexture
glDeleteTextures
glGenTextures

are still marked as undeclared for scc contained in fnt95 environment 8.61.
Unfortunately this is not healed by copying the good version of gl.h of ftn95 environment 8.50 to the 8.61 environment.

This confuses me.

Regards,
Dietmar
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6472
Location: Salford, UK

PostPosted: Thu Apr 02, 2020 4:07 pm    Post subject: Reply with quote

Dietmar

I am sorry for the ongoing problem with gl.h.

Can you look at ...\Silverfrost\FTN95\include\gl\gl.h.

This appears to be the place where the installer has put the file and it should be placed at ...\Silverfrost\FTN95\include\win32\gl\gl.h.

Please let me know if this resolves the problem so that I can pass the information on.

Paul
Back to top
View user's profile Send private message AIM Address
DietmarSiepmann



Joined: 03 Jun 2013
Posts: 239

PostPosted: Fri Apr 03, 2020 7:53 am    Post subject: Reply with quote

Paul,

yes, this helped and resolved the problem.

Thanks
Dietmar
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group