forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Debugger does not show value of long character strings

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
StamK



Joined: 12 Oct 2016
Posts: 113

PostPosted: Wed Nov 27, 2019 6:06 pm    Post subject: Debugger does not show value of long character strings Reply with quote

Run the following code
Code:

!ftn95$free

program main
CHARACTER*9000   :: CH
    CHARACTER*1 C1

       CH  =  " "
     
   DO I = 1, len(ch)
    c1 = 'H'
    CH(I:I) = C1
   END DO
   print*,"ch=",trim(ch)
end program


If you put a breakpoint on the print statement, then CH appears to be empty. When reducing the size of CH to (say) 90, then it shows it correctly.
The print statement does show CH correctly in all cases.
Back to top
View user's profile Send private message
StamK



Joined: 12 Oct 2016
Posts: 113

PostPosted: Mon Dec 02, 2019 10:46 am    Post subject: Reply with quote

I have been advised that if you right-click on the variable and choose Memory dump you can see the value.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group