forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

no output using x64 compilation but ok on win32 ??

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
DoLBest



Joined: 06 Jul 2019
Posts: 1

PostPosted: Sat Jul 06, 2019 8:40 pm    Post subject: no output using x64 compilation but ok on win32 ?? Reply with quote

I have recently reloaded silverfrost but now find I am having a problem printing to a file. See simple program below. It works when compiled under win32. The program runs when compiled under x64 but nothing is printed to file. What am I missing? Appreciate any help.

Program Simple_test
open(10,file='test.out')
write(10,20)
20 format('this is a test')
stop
end
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6071
Location: Salford, UK

PostPosted: Sun Jul 07, 2019 8:08 am    Post subject: Reply with quote

It works OK for me.

I am using the latest clearwin64.dll and that might make a difference.

Try calling close(10) before exiting.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group