forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Icon and resource issue

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
jcherw



Joined: 27 Sep 2018
Posts: 27
Location: Australia

PostPosted: Wed Nov 28, 2018 2:37 am    Post subject: Icon and resource issue Reply with quote

My program uses an icon. The .ico file is in the 'Resource files' folder of Plato (when I click on it Plato opens it in picture editor window.

The main code hast the following statements:

winapp 'simu3icon'

.... lots of code lines

ans=winio@('%mi[simu3icon]&')

.... lots of code lines

resources
simu3icon ICON hstsimu3.ico

and the icon file is available in the same folder as the source.

When compiling I get the error
*** Unable to open file HSTSIMU3.ICO

Any suggestion what the problem is woudl be very welcom




Back to top
View user's profile Send private message
John-Silver



Joined: 30 Jul 2013
Posts: 959
Location: Aerospace Valley

PostPosted: Wed Nov 28, 2018 2:54 am    Post subject: Reply with quote

G'day jcherw Smile
which version of FTN95 are you using and which version of windows ?

Are you compiling in x32 or x64 mode ?

Try just running the resource compiler with the resource file and see if that runs ok or not.
_________________
''Computers are incredibly rigid. They question nothing. Especialy input data.Human beings are incredibly trusting of computers and don't check input data. Together they are capable of cocking up even the simplest calculation ... Smile "
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5584
Location: Salford, UK

PostPosted: Wed Nov 28, 2018 9:39 am    Post subject: Reply with quote

The most likely explanation is that more information is needed on where to find the file.

The short name that you have used will only work if the resource compiler is operating in the same folder as the icon file or if it is "visible" via the PATH environment variable.

Try using the full path to the icon file (using double quotes if it contains spaces). If that works then you can also try other ways such as providing a relative path, copying the file to a more accessible place etc.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group