forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

%BB behaviour in Win XP/Win10
Goto page Previous  1, 2
 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
steveDoyle



Joined: 04 Sep 2009
Posts: 58
Location: Manchester

PostPosted: Mon Jul 24, 2017 12:55 pm    Post subject: Re: Reply with quote

PaulLaidler wrote:
If ClearWin+ can be demonstrated to behave inconsistently then please post a simple demo so that it can be fixed.


HI Paul

see my original thread. %bb does not refresh after change of grey control on XP. they go from greyed to blank. moving cursor over button then paints the button with un-greyed image

it works fine on win 7/win10

%bt behave on xp/7/10
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5040
Location: Salford, UK

PostPosted: Tue Jul 25, 2017 8:05 am    Post subject: Reply with quote

Steve

I have had a look at this but unfortunately I have only just dismantled my XP testing environment. In mitigation I would point out that a) %bb may well have been developed post XP and b) there have been at least 4 versions of the OS since XP.

I recommend using %bt (for XP) rather than %bb. You could test the OS version (GET_OS_VERSION@) and switch between %bb and %bt in the code.
Back to top
View user's profile Send private message
steveDoyle



Joined: 04 Sep 2009
Posts: 58
Location: Manchester

PostPosted: Tue Jul 25, 2017 8:13 am    Post subject: Reply with quote

HI Paul

I have already started implementing such a os version based button system but with over 3000 %BB across 15 apps its going to be a labour of love

steve
Back to top
View user's profile Send private message
steveDoyle



Joined: 04 Sep 2009
Posts: 58
Location: Manchester

PostPosted: Tue Jul 25, 2017 8:39 am    Post subject: Reply with quote

HI Paul

Can i just confirm that you are stating that XP is no longer supported

regards

steve
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5040
Location: Salford, UK

PostPosted: Tue Jul 25, 2017 9:07 am    Post subject: Reply with quote

Steve

No. Not absolutely. If a user encounters a XP bug that does not have a work-around then it may be possible for us to provide a fix particularly if it can demonstrated on a more recent OS.
Back to top
View user's profile Send private message
LitusSaxonicum



Joined: 23 Aug 2005
Posts: 1683
Location: Yateley, Hants, UK

PostPosted: Tue Jul 25, 2017 1:57 pm    Post subject: Reply with quote

Steve,

Have you experimented with providing an icon for a %bt using %bi, and does this work in XP? Reading FTN95.CHM suggests that such an icon is limited to 32x32 bits, which is rather large, but I do wonder if that is correct. The syntax for %bi suggests that it might be easier to splice that in to a WINIO@ than the ordinary syntax for %bb.

Eddie
Back to top
View user's profile Send private message
steveDoyle



Joined: 04 Sep 2009
Posts: 58
Location: Manchester

PostPosted: Tue Jul 25, 2017 2:16 pm    Post subject: Reply with quote

Eddie
I have not tried that approach. I will try a few experiement

I'm about half way though the conversion using OS dependent selection of %bb or %BT. As the issue is with buttons with a grey control i can easily detect this within input forms reducing the overall conversion requirement

thanks

steve
Back to top
View user's profile Send private message
steveDoyle



Joined: 04 Sep 2009
Posts: 58
Location: Manchester

PostPosted: Mon Aug 21, 2017 10:37 am    Post subject: Reply with quote

Paul


I have seen the blank button after an ungrey behaviour on a Win 10 laptop (i think its a win 7/8/8.1 upgrade) (compiled/built on win 7 pc). It works as expect on my win 10 pro laptop.

regards

steve
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5040
Location: Salford, UK

PostPosted: Mon Aug 21, 2017 1:36 pm    Post subject: Reply with quote

Steve

I am wondering why you have posted this information. We can only fix faults that can be reproduced from working code.
Back to top
View user's profile Send private message
steveDoyle



Joined: 04 Sep 2009
Posts: 58
Location: Manchester

PostPosted: Mon Aug 21, 2017 2:07 pm    Post subject: Reply with quote

Hi Paul

I was just trying to alert other users to the possible behaviour. If it was just isolated to win XP then the behaviour could be controlled using version dependent code. Different behaviour of the same code on what should be the same OS is harder to handle


steve
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group