forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

False "include" files when moving a project

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Plato
View previous topic :: View next topic  
Author Message
sparge



Joined: 11 Apr 2005
Posts: 371

PostPosted: Tue Nov 14, 2006 7:50 am    Post subject: False "include" files when moving a project Reply with quote

If I move an existing project folder to a new path, and then open the project file, I get a series of error messages about the source files not existing. When they are all acknowledged, I end up with all the source files in the right place in the project explorer pane (but not actually open in the main window) anyway. But I also get a corresponding set of source files, qualified with the previous path, that have been classed as include files. Trouble is, there is no way (that I can find) to remove them from within Plato - right-clicking them only gives an option to Open them, which can't be done either because they're not there any more.

There seems to be a workaround - close Plato, open the project ini file, and there, between [Handles] and [Modules] is a series of lines that correspond to these "include" files. Deleting these lines appears to have the desired effect - when I reopen the project file, all appears to be well.

Is this workaround complete i.e. there are no further gotchas that are not apparent from the ini file? Would it be possible to fix this in a future release, please? Either allow include files to be deleted from the project within the IDE, or better, stop them being included as include files in the first place?

TIA,

Andy
Back to top
View user's profile Send private message Send e-mail
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5604
Location: Salford, UK

PostPosted: Tue Nov 14, 2006 10:26 am    Post subject: False "include" files when moving a project Reply with quote

Andy

I think the thing to do is to try the next release.
I am aware of problems in this area but I do not have time just now to address them.
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5604
Location: Salford, UK

PostPosted: Wed Nov 15, 2006 12:37 am    Post subject: False "include" files when moving a project Reply with quote

Andy

I forgot to mention the "Rebuild Dependencies" should clear away the offending files but you have probably tried this.
Back to top
View user's profile Send private message
sparge



Joined: 11 Apr 2005
Posts: 371

PostPosted: Wed Nov 15, 2006 3:38 am    Post subject: False "include" files when moving a project Reply with quote

Actually I hadn't! Thank you for mentioning it - I'll try it.

It seems Rebuild Dependenices might be even more of a panacea than I had it down for - I frequently have to do that after changing some code, to avoid modules getting compiled in the wrong order. I'm pretty sure I've mentioned this before - something else I am hoping will be fixed in the next release.

Any idea when the next release will be?
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Plato All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group