forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Odd message unconnected with the actual error

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> ClearWin+
View previous topic :: View next topic  
Author Message
LitusSaxonicum



Joined: 23 Aug 2005
Posts: 2360
Location: Yateley, Hants, UK

PostPosted: Fri Jan 13, 2023 1:41 pm    Post subject: Odd message unconnected with the actual error Reply with quote

A friend of mine made the mistake of attempting to set the font on a drawing surface with WINIO@ and %fn instead of SET_FONT@ (and also returning to the default with WINIO@ and %sf). He got an odd error message saying that he couldn’t use %bx inside an %ob…%cb structure!

The error was pretty easy for me to spot when I saw the source code, but on the basis of knowledge of what it should have been rather than from the error message.

I don’t think that producing a demonstrator is worth the effort, and Paul, you’d be wasting your time trying to provide an error message for it. But it did confuse my pal!

Eddie
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> ClearWin+ All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group