forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Linker Parsrf

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit
View previous topic :: View next topic  
Author Message
stfark1



Joined: 02 Sep 2008
Posts: 210

PostPosted: Tue Feb 22, 2022 9:09 pm    Post subject: Linker Parsrf Reply with quote

Running Win10 and Silverfrost Fortran, debug64. When I perform the link, I get a notification that one of my routines is loaded more than once. However, the culprit is not shown in any of the object files with that name. I do have a routine of that name but only compiled once into the Debug64 folder?? Any ideas on how to resolve or where I can find the place that the routine is called or loaded twice? Sid kraft
Back to top
View user's profile Send private message
wahorger



Joined: 13 Oct 2014
Posts: 1161
Location: Morrison, CO, USA

PostPosted: Tue Mar 01, 2022 11:10 pm    Post subject: Reply with quote

Try a full rebuild. Sometimes, if you have modified a routine (pulled out some code) and created a new source, the old object can get "left behind".

At least, it has happened to me more than once!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group