forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Using HELP files

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
wahorger



Joined: 13 Oct 2014
Posts: 654
Location: Morrison, CO, USA

PostPosted: Fri Sep 27, 2019 3:09 pm    Post subject: Using HELP files Reply with quote

I have run across something I cannot duplicate in a "trivial" program. And, I cannot tell if it is a problem in the HELP interface within ClearWin or the source document (built with HelpScribble).

I am using a function call to set the "Help" menu choice at the end of building a Window. When I invoked HELP, what I would see in the MS Help display of the CHM file was the string I was looking for PLUS other string information. It was as if the separator (or end-of-characters character) was missing from the API call.

The fix: So, in my function, I append a CHAR(0) to the end of the topic string which is passed as CHARACTER*(*). This appears to work consistently now. But I have not exhaustively tested this in full operations.

My question is: Since the string is built at run-time (appending the CHAR(0)) and uses the stack, am I at risk of having the Help topic being over-written whilst the program is interacting with the user?
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group