forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problem with graphic region and mouse cursor

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
dgurok



Joined: 26 May 2011
Posts: 56

PostPosted: Wed Apr 10, 2019 8:54 am    Post subject: Problem with graphic region and mouse cursor Reply with quote

Hello,

we have observed a strange behavior with respect to graphic region (%gr).

On some machines with Windows 10 the mouse cursor disappears when we enter the graphic region with mouse cursor. When we left the graphic region the mouse cursor is visible again.

Did someone have observed the problem too? How can I fix it?

Iím using FTN95 version 7.10.0.
Back to top
View user's profile Send private message
LitusSaxonicum



Joined: 23 Aug 2005
Posts: 2056
Location: Yateley, Hants, UK

PostPosted: Wed Apr 10, 2019 9:52 am    Post subject: Reply with quote

It depends on what the background colour of the %gr is. I can't remember exactly now, but I think it was a mid-grey. The answer, if you can't change the colours selected for your graphics, is to use a different cursor. The standard crosshair is simple and effective, but it is subject to the behaviour you describe.

You change cursors by listing them in RESOURCES and then using %cu. There are some great cursors on the web, free. I use some that were put on the web by Vlastimir Miler - you can search for them. If the cursor visibility is still a problem you can use animated cursors.

Eddie
Back to top
View user's profile Send private message
dgurok



Joined: 26 May 2011
Posts: 56

PostPosted: Wed Apr 10, 2019 1:23 pm    Post subject: Reply with quote

It's true, depending on background color (~grey) the mouse cursor is not visible. But in this case all machines are affected. We tried different colors and on some machines with Windows 10 we have this strange effect. It's strange because not all Windows 10 machines are affected.

I will try it with a customized mouse cursor.
Back to top
View user's profile Send private message
LitusSaxonicum



Joined: 23 Aug 2005
Posts: 2056
Location: Yateley, Hants, UK

PostPosted: Wed Apr 10, 2019 2:53 pm    Post subject: Reply with quote

"Why?" is a difficult question. "What to do about it" is "Use a more elaborate cursor". The reason it is not the same on all Windows 10 machines is that they may have different monitors, different graphics systems, different graphics drivers and so on. Windows 8 and 10 are "optimised" (i.e. downgraded) so that they work on devices like tablets and phones with pathetically useless processors.

At least Clearwin+ has most of the tools to defeat the worst that Microsoft can do in the name of "progress".

Eddie
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group