forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

New status bar?

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> ClearWin+
View previous topic :: View next topic  
Author Message
LitusSaxonicum



Joined: 23 Aug 2005
Posts: 1844
Location: Yateley, Hants, UK

PostPosted: Thu Aug 02, 2018 9:32 pm    Post subject: New status bar? Reply with quote

I'm getting the message:

The procedure entry point __set_status_text could not be
located in the dynamic link library
C\ etc \lgotemp@.exe

Using 32-bit mode, 8.30PE and:

Code:
      WINAPP
      OPTIONS (DREAL, INTL)
      PROGRAM STATUS
      INCLUDE <WINDOWS.INS>
      COMMON IAR(10), Ihnd
      INTEGER, EXTERNAL :: StartFN
      IAR =10
      N1 = 300
      N2 = 200
      IA = WINIO@('%ca[Status bar test]&')
      IA = WINIO@('%sc&',        StartFN)
      IA = WINIO@('%gr[Black]&', N1, N2)
      IA = WINIO@('%5sb&',       IAR)
      IA = WINIO@('%lc',         Ihnd)
      END
      INTEGER FUNCTION StartFN()
      INCLUDE <WINDOWS.INS>
      COMMON IAR(10), Ihnd
      Call Set_status_Text@ (Ihnd, 0, 'Help')
      Call Set_status_Text@ (Ihnd, 1, '1')
      Call Set_status_Text@ (Ihnd, 2, '2.0')
      Call Set_status_Text@ (Ihnd, 3, '3 step')
      Call Set_status_Text@ (Ihnd, 4, '4.345')
      StartFN = 2
      END


Any ideas?

Eddie
Back to top
View user's profile Send private message
mecej4



Joined: 31 Oct 2006
Posts: 976

PostPosted: Fri Aug 03, 2018 1:09 am    Post subject: Reply with quote

The entry point __set_status_text is present in the SALFLIBC.DLL that came with FTN95 8.30.169, but not in the SALFLIBC.DLL of FTN95 7.20.0.

Please check if you have a mismatched version of SALFLIBC.DLL in the list of paths in %PATH%. You can, for example, use the command

WHERE SALFLIBC.DLL
Back to top
View user's profile Send private message
LitusSaxonicum



Joined: 23 Aug 2005
Posts: 1844
Location: Yateley, Hants, UK

PostPosted: Sat Aug 04, 2018 6:33 pm    Post subject: Reply with quote

Thanks Mecej4, I had checked that the path pointed at the correct Salflibc.dll, and that I did not have a local (outdated) copy, but something else is going on. I then made a local copy in the subdirectory I'm working in, and now it works. Actually looks quite nice, and is subtly different with and without the default.manifest. But why it didn't work before I can't guess. Probably because even though it was on the path, Windows has its own hidden path it checks first! Having a local copy puts it in the first place Windows looks!

Nice enhancement Paul.

Eddie
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> ClearWin+ All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group