forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Serious graphic problem with %im in 8.30

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
silicondale



Joined: 15 Mar 2007
Posts: 204
Location: Matlock, Derbyshire, UK

PostPosted: Tue Apr 17, 2018 12:37 pm    Post subject: Serious graphic problem with %im in 8.30 Reply with quote

I have some code for selection of a colour ramp which worked perfectly before, using 2 x n boxes. n was originally set to 11 but I have now reduced it to 4 to demonstrate the problem.

In 8.30 it now increases the height of the box for each row of boxes added. Like this...


and elsewhere the image height is set wrongly too.
Here is the snippet of code for the colour ramps.

Code:

        jj = winio@ ('%ww[thin_border]%ca[select colour ramp]&')
        jj = winio@ ('%11`ga&',k(1),k(2),k(3),k(4),k(5),k(6),
     1                        k(7),k(8),k(9),k(10),k(11))
        jj = winio@('%ff%nl%2.4ob[thin_margin,bottom_exit]&')
        maxcr = 4
        do i=1,maxcr
          crname='{'//prog_path_name(1:lenppn)//'cramp\'//crfl(i)//'}'
          lencr = len_trim(crname)

          if (ndebug.gt.0) write (idsply,5501) i,lencr,crname(1:lencr)
5501      format ('i=',i2,' lencr=',i5,' crname=',a)

          jj=winio@('%rb@%cb&',crx(i),k(i))
          jj=winio@('%im@%cb&',crname(1:lencr))
        end do
        jj = winio@ ('%ff%^bt[ok]','exit')


The graph window doesn't use boxes, just %im to display the colour ramp image below a %pl graph

The colour ramp image files are all the same size .jpg files, 256 x 32 pixels

This is a serious bug and one that needs urgent attention !
_________________
(just call me Steve)
Back to top
View user's profile Send private message Visit poster's website
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5305
Location: Salford, UK

PostPosted: Tue Apr 17, 2018 12:48 pm    Post subject: Reply with quote

A fix is already available. Here is a link to new DLLs and other information...

https://www.dropbox.com/s/6zjxnvmlgvrx4ov/newDLLs23.zip?dl=0
Back to top
View user's profile Send private message
silicondale



Joined: 15 Mar 2007
Posts: 204
Location: Matlock, Derbyshire, UK

PostPosted: Tue Apr 17, 2018 1:22 pm    Post subject: Reply with quote

Many thanks! That was quick. Impressed by your response Very Happy
_________________
(just call me Steve)
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group