forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

concerning linker errors

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit
View previous topic :: View next topic  
Author Message
Carl_Mesaros



Joined: 28 Nov 2016
Posts: 8

PostPosted: Tue Nov 21, 2017 9:38 pm    Post subject: concerning linker errors Reply with quote

Dear Silverfrost Community:
I just try to implement a regular program, use the Advanced Save
Option, and, when I try to implement the program, all that results is a
"internal linker error" message, nothing else. What am I doing wrong?
Thank you. Smile
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5092
Location: Salford, UK

PostPosted: Tue Nov 21, 2017 10:10 pm    Post subject: Reply with quote

Why are you using the "advanced save"?

Please supply more details of the steps that you are taking. I guess that you are compiling, linking and running from Plato. Is that the case and what are the steps?
Back to top
View user's profile Send private message
Carl_Mesaros



Joined: 28 Nov 2016
Posts: 8

PostPosted: Wed Nov 22, 2017 4:30 pm    Post subject: Reply with quote

Dear Mr. Laidler:
I am using the Silverfrost FTN95 compiler. If you need further information,
let me know just what information you need. Thank you. Smile
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5092
Location: Salford, UK

PostPosted: Wed Nov 22, 2017 5:32 pm    Post subject: Reply with quote

If you are using Plato to edit your files then the "advanced save" option on the File menu should NOT be used except to convert a non-ASCII encoding back to ASCII. You should also use the "Windows" line endings.

When creating a file, just save it directly without using the "advanced save" option.

The FTN95 compiler assumes ASCII encoding and "Windows" line endings (although other settings might work in particular circumstances).

If you have used the Plato toolbar to compile and link then everything should be OK. If not then describe what actions you took to get the linker to run.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group