forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

run time issues

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> General
View previous topic :: View next topic  
Author Message
asposaro



Joined: 10 Jul 2016
Posts: 1

PostPosted: Tue May 23, 2017 10:04 am    Post subject: run time issues Reply with quote

Hello everybody. I am running some executables using a new machine where I installed a new version of silverfrost. I already have another machine with silverfrost installed and when I compile the same code and same options, the run time that the program takes is very quick (5 minutes). If I compile and run the program with the new machine the runtime become 45 minutes. The machines are running two different versions of Silverfrost. The fast one has an old Version that I haven't updated yet (7.10) while the slow one has the latest version. this are the options I'm using at the moment for compiling. Could you please help? thanks a lot!

Slow machine:
Quote:
ftn95 $< /defint_kind 3 /deflog_kind 1 /no_com /ch /de /fu /im /mod_path \source\mods /cfpp /define DEBUG 1 $(ARGS) >>\compall.txt


quick machine:
Quote:
ftn95 $< /defint_kind 3 /deflog_kind 1 /no_com /debug /full /c /im /mod_path \source\mods /cfpp /define DEBUG 1 $(ARGS) >>\compall.txt
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 4819
Location: Salford, UK

PostPosted: Tue May 23, 2017 10:56 am    Post subject: Reply with quote

To avoid confusion could you use the same form for the command line in the two cases otherwise we have to work out if /c is the same as /ch etc..
Back to top
View user's profile Send private message
JohnCampbell



Joined: 16 Feb 2006
Posts: 1739
Location: Sydney

PostPosted: Tue May 23, 2017 12:31 pm    Post subject: Reply with quote

I changed the first command to the following .bat syntax
Quote:
ftn95 /defint_kind 3 /deflog_kind 1 /no_com /ch /de /fu /im /cfpp /define DEBUG 1 %1 /lis >>compall.txt

( I basically removed the /mod_path option )
The resulting report was
Code:
Silverfrost FTN95/Win32 Ver 8.10.0  insert_comma.f90  Tue May 23 21:21:21 2017

Compiler Options in Effect:
    CFPP CHECK COLOUR DEBUG DEFINE DEFINT_KIND 3 DEFLOG_KIND 1 DELETE_OBJ_ON_ERROR
    ERROR_NUMBERS FULL_DEBUG IMPLICIT_NONE INTL LIST LOGL MINIMISE_REBUILD  NO_COMMENT
    NO_QUIT NON_STANDARD SINGLE_THREADED
 


I tried your second as:
Quote:
ftn95 /defint_kind 3 /deflog_kind 1 /no_com /debug /full /c /im /cfpp /define DEBUG 1 %1 /lis >>compall.txt

The result was that /c started the FTN95 Local Configuration window with no compilation performed. You need to review the command you posted or the date stamp of the .obj file you are using on the new machine.

This was done with FTN95/Win32 Ver 8.10.0, but I suspect there would be little change with earlier versions.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> General All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group