forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

got a strange read error

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
KennyT



Joined: 02 Aug 2005
Posts: 247

PostPosted: Wed Feb 15, 2017 7:51 pm    Post subject: got a strange read error Reply with quote

I'm getting a floating point error, with the following line:

Code:
READ (NU, REC=IREC, iostat=IOS, err=9000) IVAL, NXTREC, LSTREC, ICVER


which seems strange because it doesn't go to the err= line and the 4 variables that it's reading are all INTs!

any ideas?


K
Back to top
View user's profile Send private message Visit poster's website
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 4910
Location: Salford, UK

PostPosted: Wed Feb 15, 2017 9:47 pm    Post subject: Reply with quote

I think that the err return would be for an error in the data whereas this appears to be something to do with the type of the variables.

Are you sure that they are all integers?
Back to top
View user's profile Send private message
KennyT



Joined: 02 Aug 2005
Posts: 247

PostPosted: Wed Feb 15, 2017 10:48 pm    Post subject: Reply with quote

i've emailed you a couple of screen grabs from SDBG...

let me know if you need anything else.

K
Back to top
View user's profile Send private message Visit poster's website
mecej4



Joined: 31 Oct 2006
Posts: 732

PostPosted: Thu Feb 16, 2017 6:47 pm    Post subject: Reply with quote

My guess is that you have project settings or compiler options that cause the integers being read to be 8-byte integers, since FTN95 processes 8-byte integers using X87 instructions and the X87 register stack ST0-7.
Back to top
View user's profile Send private message
KennyT



Joined: 02 Aug 2005
Posts: 247

PostPosted: Fri Feb 17, 2017 4:58 pm    Post subject: Reply with quote

thanks, but under SDBG i can see that the variables being read are all INT*4s and the binary data being read are all valid (e.g. hex 77), so it remains a mystery for now.

Anyway, i've sent the data and a debuggable app to Silverfrost, so i'll wait and see what they find.

K
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group