forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Getting DISLIN working properly

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
arctica



Joined: 10 Sep 2006
Posts: 69
Location: United Kingdom

PostPosted: Tue Jul 23, 2013 1:51 pm    Post subject: Getting DISLIN working properly Reply with quote

Hello,

I have downloaded and installed the DISLIN package (10.3) and looking at the files it seems only a few key ones are required from the setup.

Directory of C:\Fortran95-work\DISLIN_lib

19/07/2013 10:46 432,128 disdll.dll
19/07/2013 10:47 433,664 disdll_d.dll
11/07/2013 14:28 116,718 dislin.f90
23/07/2013 13:35 46,570 DISLIN.MOD
11/07/2013 14:28 120,968 dislin_d.f90
15/07/2013 16:13 46,514 dislin_d.mod
19/07/2013 11:07 2,164,224 diss32.dll
19/07/2013 11:07 692,402 diss32.lib
19/07/2013 11:08 2,806,784 diss32_d.dll
19/07/2013 11:08 694,760 diss32_d.lib

I compiled the Dislin module, so that was all fine. Not too sure what the order of things is in the project:

Sources: dislin.f90
exa.f90.f90
Include -
Resources -
Reference: disdll.dll
diss32.dll
diss32.lib

The program compiles and links without errors, falls over at one point in run-time saying that diss32.dll is missing/not installed, even though I explicitly put it in the list.

Is it absolutely required to set the environment variables as it suggests?
I am only looking at single precision at the moment. It must read the .lib file ok as without it complains of missing symbols, so I know it is seeing the folder where the files are.

Cheers
Lester
Back to top
View user's profile Send private message
arctica



Joined: 10 Sep 2006
Posts: 69
Location: United Kingdom

PostPosted: Mon Jul 29, 2013 8:48 am    Post subject: Reply with quote

Problem sorted

Cheers
Lester
Back to top
View user's profile Send private message
paolo



Joined: 12 Sep 2017
Posts: 1

PostPosted: Tue Sep 12, 2017 10:13 am    Post subject: Reply with quote

Hi Lester,

I have the same problem. How did you solve it?

Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group