forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

FTN95+Visual Studio 2003 Debugging Problem

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
Anonymous
Guest





PostPosted: Tue Feb 15, 2005 3:38 am    Post subject: FTN95+Visual Studio 2003 Debugging Problem Reply with quote


Hello. I'm working with the free version Salford FTN95 4.60 PE and Visual Studio 2003 .NET.
I use the included Debugger of Visual Studio to debug in modus "Debug Win32".
Normally comes at the beginning of the debugging a screen for some seconds to show that
this is the free version and then I see the command prompt and the debugging starts.

But strangely now comes directly the the command prompt window, but nothing else. The cpu
works at 100% but there is only the black screen there.

Release mode Win32, and Debug mode Win32 with Salford Debugger are working and also
all sorts of NET are working. Only Debug mode Win32 with Visual Studio Debugger isn't
working (which is the one I need)...

Uninstallation and then new installation of Salford FTN95 and Visual Studio didn't help.
Also upgrade to FTN 4.70 didn't help

Has somebody an idea what to do??????




sonyc
Back to top
silverfrost
Site Admin


Joined: 29 Nov 2006
Posts: 153
Location: Manchester

PostPosted: Tue Feb 15, 2005 1:07 pm    Post subject: FTN95+Visual Studio 2003 Debugging Problem Reply with quote

Have you ever been able to use the FTN95 Win32 debugger within Visual Studio 2003?

What OS do you have?


------------
Administrator
Silverfrost Forums
Back to top
View user's profile Send private message Visit poster's website
Andrew



Joined: 09 Sep 2004
Posts: 232
Location: Frankfurt, Germany

PostPosted: Tue Feb 15, 2005 1:12 pm    Post subject: FTN95+Visual Studio 2003 Debugging Problem Reply with quote

When you say the CPU is at 100% - what is actually taking up that 100% is it Visual Studio (devenv.exe) or your program?

If you are experiencing problems it is possible to launch the Salford debugger from inside Visual Studio .NET by making a change in the configuration options for the project. If you open the project properties page and select:

Compiler Options -> Miscellaneous and change the Win32 Debugger type to Salford SDBG then this will launch the Salford debugger from inside Visual Studio. If the integrated debugger does not work for your program then this is a possible workaround. This problem does seem to be related to your program as debugging Win32 applications with the integrated debugger certainly is possible with FTN95.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group