forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Viewing dynamically allocated arrays in FTN95 SDBG debugger

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
Anonymous
Guest





PostPosted: Sat Dec 18, 2004 9:04 pm    Post subject: Viewing dynamically allocated arrays in FTN95 SDBG debugger Reply with quote

I have just converted my code from FTN77 to Personal FTN95, and in the process switched throughout from placing arrays in COMMON and instead dynamically allocating them. Specifically, all my arrays are now declared in a module, for example
REAL*8 , DIMENSION(Smile, ALLOCATABLE :: B

and then in the relevant subroutine their sizes are allocated, for example
ALLOCATE ( B(100) )

I run using the command line environment with the source debugger SDBG. My code compiles and runs with FTN95 fine as before. However, in SDBG, every time I place the cursor over any array name (say B) in the source code, it displays B=POINTER::(100). Right clicking with the mouse produces an array display window with every array element indicated as "pointer type is null". So I have no debugging capability and this of course makes FTN95 unusable.

Have I hit a fatal limitation of FTN95 in command line mode, or am I doing something wrong? Is there a cure or workround? Thanks in anticipation

Brian Stott
Back to top
silverfrost
Site Admin


Joined: 29 Nov 2006
Posts: 153
Location: Manchester

PostPosted: Mon Dec 20, 2004 9:08 am    Post subject: Viewing dynamically allocated arrays in FTN95 SDBG debugger Reply with quote

Have you tried version 4.70 ?

------------
Administrator
Silverfrost Forums
Back to top
View user's profile Send private message Visit poster's website
Anonymous
Guest





PostPosted: Mon Dec 20, 2004 11:25 am    Post subject: Viewing dynamically allocated arrays in FTN95 SDBG debugger Reply with quote

To the administrator: Many thanks for your help - I was using 4.6. I have just tried 4.7 and the problem has gone away.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group