forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Strange Error

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Plato
View previous topic :: View next topic  
Author Message
stfark1



Joined: 02 Sep 2008
Posts: 121

PostPosted: Fri Oct 29, 2010 10:42 pm    Post subject: Strange Error Reply with quote

I have been using SilverFrost fortran for a while. Since vers. 5.4, now 5.5, I have been getting a strange error, I believe from Fortran. The error states "The process cannot access the file because it is being used by another process". This error "pops up" at different times during debugging with Plato. There seems to be no condition of repetition, just occurs, "out of the blue" Anybody have any ideas or have experienced this also? Sid Kraft
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5369
Location: Salford, UK

PostPosted: Sat Oct 30, 2010 10:32 am    Post subject: Reply with quote

If this error message occurs whilst your program is running then you need to find the point at which the program is failing and the file that is being accessed. /checkmate can be useful for this. Start up the debugger and run the program till it fails.

The error message means what it says. Maybe you have failed to close down another application (or another instance of the same application) that is using the same file. Unless you open the file with the necessary parameters, only one process at a time is allowed to open a file.
Back to top
View user's profile Send private message
stfark1



Joined: 02 Sep 2008
Posts: 121

PostPosted: Sun Nov 07, 2010 5:35 pm    Post subject: Strange Error Reply with quote

Hi Paul: Still trying to detect where my program is getting the "system file error, trying to access a file which is being used by another program", I went to "project Properties", checked the box "call debug_source@", ran program, listed many "-trace nnn" lists, never failed, completed normally! How else can I access to get the error? Is very frustrating that it occurs so sporadically. Sid Kraft
Back to top
View user's profile Send private message
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 5369
Location: Salford, UK

PostPosted: Mon Nov 08, 2010 1:54 pm    Post subject: Reply with quote

You need to start and run your executable from SDBG. You can run SDBG directly or fire it up from Plato by pressing F7.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Plato All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group