forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

SDBG when compiling with /undef

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support
View previous topic :: View next topic  
Author Message
KennyT



Joined: 02 Aug 2005
Posts: 270

PostPosted: Thu Aug 04, 2005 6:17 am    Post subject: SDBG when compiling with /undef Reply with quote

Hi, I'm posting this again just in case it's got lost from it's original posting from a few weeks ago...

If we compile a program with /undef, should there be an undefined variable, running normally shows a crash stack as expected. However, when running under SDBG, it stops when it hits the 'undef' but the stack and code isn't shown, making debugging a bit tedious!

K
Back to top
View user's profile Send private message Visit poster's website
Anonymous
Guest





PostPosted: Thu Aug 04, 2005 4:20 pm    Post subject: SDBG when compiling with /undef Reply with quote

What does it show in the call stack? I have just tried an example and it did exactly what I expected. Does the error message mention Error 112?
Back to top
KennyT



Joined: 02 Aug 2005
Posts: 270

PostPosted: Fri Aug 05, 2005 12:11 am    Post subject: SDBG when compiling with /undef Reply with quote

Yes, it mentions error 112 but then it just says 'unknown' for the stack. The main window shows assembler code with the lines:

7c81eb33 POP ESI
7c81eb34 LEAVE
7c81eb35 RETN

If I run it not using the debugger, I get a correct crash stack.

I've tried with a simple single .obj-based app and it's OK so maybe the problem has to do with DLLs?

I'll try to engineer a simple example, otherwise it'll need you to download our app before you can see it.

K


Back to top
View user's profile Send private message Visit poster's website
KennyT



Joined: 02 Aug 2005
Posts: 270

PostPosted: Sat Aug 06, 2005 8:31 am    Post subject: SDBG when compiling with /undef Reply with quote

Rob,

I've pm-ed you with a version for you to play with that shows the problem...

K
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> Support All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group