forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Default button callback value not returned to parent

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> ClearWin+
View previous topic :: View next topic  
Author Message
wahorger



Joined: 13 Oct 2014
Posts: 1011
Location: Morrison, CO, USA

PostPosted: Tue Jun 22, 2021 2:30 am    Post subject: Default button callback value not returned to parent Reply with quote

The following code should, when a ENTER is done, return the value 400 as the value from the closure of the window. It does not. Clicking the button will, however.

This function works as it should if the button is NOT in the child window.

Code:

        winapp
        program main
        integer,external:: runx
        integer:: ret_val
        integer(7):: child
        data ret_val/5/
        i = winio@('%sh&',child)       
        i = winio@('%`^bt[Change]%nl&',runx)
        i = winio@('%bt[Not Default]')
        i = winio@('%ch&',child)
        i=winio@('%`rd', ret_val)
        print *,i
        end
        integer function runx()
        use mswin
        runx = -400
        return
        end
Back to top
View user's profile Send private message Visit poster's website
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 7142
Location: Salford, UK

PostPosted: Tue Jun 22, 2021 7:49 am    Post subject: Reply with quote

Bill

Is this a regression or has it never worked?

I will take a look at it as soon s possible.
Back to top
View user's profile Send private message AIM Address
wahorger



Joined: 13 Oct 2014
Posts: 1011
Location: Morrison, CO, USA

PostPosted: Tue Jun 22, 2021 1:11 pm    Post subject: Reply with quote

This appears to be a regression. I (vaguely) remember reporting something like this long ago, where a callback value did not have an effect on the parent. I can't seem to find the post, and it might not be from a default button like this is. I seem to remember that it was clicking a button in a child window (most likely %ps usage) and it did not return the value to the parent for closing the window.

I did check my baseline version created with compiler 8.71 and the DLL's applicable at that time, and it has this same issue.

This is not something I have done a lot of, so I don't have a series of baselined releases that I can try out to identify a time frame.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> ClearWin+ All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group