forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Cannot breakpoint at END SUBROUTINE

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit
View previous topic :: View next topic  
Author Message
StamK



Joined: 12 Oct 2016
Posts: 118

PostPosted: Mon Dec 09, 2019 12:38 am    Post subject: Cannot breakpoint at END SUBROUTINE Reply with quote

This used to be always working, and sometimes it does work, but mostly it doesn't.
As per title, if you put a breakpoint on the
END SUBROUTINE
it doesn't allow you to do that.
It used to work fine in 64bit, and it does work fine in 32bit.


Code:

SUBROUTINE TEST1
integer i2
i2=3
end subroutine   !cannot breakpoint here anymore

program main
integer i

call TEST1
end program


For reference, these are the parameters I am using
ftn95 /prog /windows /sparam 1 /debug /f2k /cfpp /64 /VPARAM bit64 1 /VPARAM debug64 1
Back to top
View user's profile Send private message
mecej4



Joined: 31 Oct 2006
Posts: 1419

PostPosted: Wed Jan 01, 2020 6:24 pm    Post subject: Reply with quote

As a work-around, you can place a RETURN statement before the END SUBROUTINE statement. You will be able to place a breakpoint on that RETURN statement when running under SDBG64.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group