forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

SLINK64 and static libraries

 
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit
View previous topic :: View next topic  
Author Message
dpannhorst



Joined: 29 Aug 2005
Posts: 162
Location: Berlin, Germany

PostPosted: Thu Jan 03, 2019 7:05 pm    Post subject: SLINK64 and static libraries Reply with quote

I try to build a 64-bit static library with slink64 (v2.01) using a command file according example 4) in theFTN95 help.

All files seem to be loaded, but when invoking the FILE command, an access violation occurs, which shows an error somewhere in build_static_library (void).

I could send my example if wanted for further investigations.

Detlef Pannhorst
Back to top
View user's profile Send private message Visit poster's website
mecej4



Joined: 31 Oct 2006
Posts: 1204

PostPosted: Thu Jan 03, 2019 9:20 pm    Post subject: Reply with quote

Did you specify the file extension sl64 when you named the output file with the file directive to SLINK64?
Back to top
View user's profile Send private message
dpannhorst



Joined: 29 Aug 2005
Posts: 162
Location: Berlin, Germany

PostPosted: Thu Jan 03, 2019 9:59 pm    Post subject: Reply with quote

I specified .sl64 as well as .lib. Both with the same reported result.
Back to top
View user's profile Send private message Visit poster's website
PaulLaidler
Site Admin


Joined: 21 Feb 2005
Posts: 6076
Location: Salford, UK

PostPosted: Thu Jan 03, 2019 10:38 pm    Post subject: Reply with quote

Detlef

Please try the latest SLINK64 using the following download. If that also fails then please send your example.

https://www.dropbox.com/s/irbvr9ugdpr11d9/Slink64.exe?dl=0
Back to top
View user's profile Send private message
dpannhorst



Joined: 29 Aug 2005
Posts: 162
Location: Berlin, Germany

PostPosted: Fri Jan 04, 2019 9:49 am    Post subject: Reply with quote

This version of SLINK64 (2.04) is working well. The extender .sl64 and .lib gave the same result.

Thanks for your quick help!

Detlef Pannhorst
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forums.silverfrost.com Forum Index -> 64-bit All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group