forums.silverfrost.com Forum Index forums.silverfrost.com
Welcome to the Silverfrost forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Search found 196 matches
forums.silverfrost.com Forum Index
Author Message
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Tue Dec 03, 2019 1:16 am   Subject:
There seems to be anything wrong with

INCLUDE <clearwin.ins>
INCLUDE <win32api.ins>
INCLUDE <win32prm.ins>

I changed everything back to INCLUDE <windows ...
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Mon Dec 02, 2019 1:40 pm   Subject:
no success.
I have to get it running without this stupid first left-click.
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Mon Dec 02, 2019 9:13 am   Subject:
it did not help
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Mon Dec 02, 2019 8:02 am   Subject:
Thanks, Paul and sorry: I was not aware that the definition is as well in win32api.ins. I had found it in MSWINMOD.F90 and WINDOWS.F90.

The problem I have is:
In my with %pl and %mg created graphi ...
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Thu Nov 28, 2019 12:42 am   Subject:
INCLUDE <clearwin.ins>
INCLUDE <win32api.ins>
INCLUDE <win32prm.ins>
::
STDCALL SENDMESSAGE 'SendMessageA' (VAL,VAL,VAL,VAL) : INTEGER&# ...
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Wed Nov 27, 2019 2:33 pm   Subject:
Paul,
I tried that as well earlier, but using:

INCLUDE <clearwin.ins>
INCLUDE <win32api.ins>
INCLUDE <win32prm.ins>
::
INTEGER*8 iResult
::
STDCALL ...
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Wed Nov 27, 2019 2:22 pm   Subject:
According to the definitions in

\Program Files (x86)\Silverfrost\FTN95\include\WINDOWS.F90 or
\Program Files (x86)\Silverfrost\FTN95\include\WINDF95.INS

the C_EXTERNAL definition should be ok ...
  Topic: Problem with SendMessage
EKruck

Replies: 17
Views: 485

PostForum: Support   Posted: Wed Nov 27, 2019 12:18 pm   Subject: Problem with SendMessage
Using SendMessage I want to send a click to my graphics Window using
C_EXTERNAL SENDMESSAGE 'SendMessage' (VAL,VAL,VAL,VAL) : INTEGER*4
::
::
CALL SendMessage  ...
  Topic: Parameter Problem
EKruck

Replies: 6
Views: 323

PostForum: 64-bit   Posted: Sat Nov 16, 2019 8:20 am   Subject:
Surprising: I compiled the complete software including all libraries anew with 8.40. The problem does not exist anymore without changes in the source code.
  Topic: Parameter Problem
EKruck

Replies: 6
Views: 323

PostForum: 64-bit   Posted: Wed Nov 13, 2019 4:47 pm   Subject: Parameter Problem
The following line provides something wrong and I cannot zoom out in the graphics.
REAL*8, PARAMETER :: FactorZoom= 1.1D0, FactorInvers= 1.0D0/FactorZoom
If I place as first executable ...
  Topic: Optimisation bug
EKruck

Replies: 5
Views: 556

PostForum: 64-bit   Posted: Wed Oct 16, 2019 3:03 pm   Subject:
Hi Paul,
in three subroutines I found severe bugs of different types compiling my 64 bit programs with /opt in FTN95 8.50. Because I cannot test everything should I better go back to 8.40?
Erwin
  Topic: Using a 32 bit DLL ?
EKruck

Replies: 1
Views: 575

PostForum: 64-bit   Posted: Mon Mar 11, 2019 12:39 pm   Subject: Using a 32 bit DLL ?
From earlier applications I have a 32 bit DLL but no source code. Is there any way to use the functions inside in a 64 bit FTN95 program ?
  Topic: COMMAND_LINE bug ?
EKruck

Replies: 2
Views: 680

PostForum: 64-bit   Posted: Sun Mar 03, 2019 4:54 pm   Subject: COMMAND_LINE bug ?
In case of no runstring parameters COMMAND_LINE provides an unexpected " instead of a blank string.
GET_COMMAND is not a real alternative, because it provides the complete string.
  Topic: %ww[casts_shadow]
EKruck

Replies: 17
Views: 4411

PostForum: ClearWin+   Posted: Sun Mar 03, 2019 8:05 am   Subject:
Paul,
my version is 8.40; the DLLs in my directory for my programs are dated Nov. 2018. I do not need a fix; I removed cast_shadow.
Erwin
  Topic: %ww[casts_shadow]
EKruck

Replies: 17
Views: 4411

PostForum: ClearWin+   Posted: Sat Mar 02, 2019 5:53 pm   Subject:
Under Win7 64 bit %ww IX = ClearWin_Info@ ('SCREEN_WIDTH') / 2 - 270
IY = ClearWin_Info@ ('SCREEN_DEPTH') / 3 - 50
MA = WINIO@ ('%bm[StartBitmap]&')
...
 
Page 1 of 14 Goto page 1, 2, 3 ... 12, 13, 14  Next
All times are GMT + 1 Hour
Jump to:  


Powered by phpBB © 2001, 2005 phpBB Group